Sponsor-Board.de
Thema geschlossen  Thema schreiben 
 Seiten (2): « Erste 1 2 Nächste > Letzte »

Lange Ladezeiten bei Plesk

Verfasser Nachricht

Beiträge: 528
Bewertung: 3
Registriert seit: Mar 2012
Status: offline


Beitrag: #1
Lange Ladezeiten bei Plesk

Guten Tag Sponsorboard Community,

Ich habe im Internet sehr lange suchen müssen, jedoch nicht zu einem zufriedenen Ergebnis kommen können.

Ich nutze auf einem Windows Root Server Plesk, um meine Website zu verwalten. In der Vergangenheit habe ich dies auf meinem Linux Server gemacht und dies lief relativ gut. Seitdem ich jedoch auf Windows umgestiegen bin, braucht meine Internet Seite zwischen 10 und 20 Sekunden zum laden.

Das ist für mich und die Leser nicht akzeptabel.

Zum Windows Server:
Windows 2016 Datacenter | Plesk | Deutsch 64 Bit
Intel® Xeon® CPU X5670 @ 2,93 GHz 1 Socket, 6 Virtuelle Prozessoren
16GB RAM

Plesk 17.8.11

Die Website besitzt ein SSL Zertifikat, läuft über HTTPS


Weitere Infos:

PHP-Logs geben keine Fehler, alles läuft normal
Die Website läuft über Plesk und nutzt 6 Plugins, eins davon um die Leistung zu verbessern
Komprimierung ist aktiviert
Läuft über Nginx
Die Auslastung der CPU liegt bei 2% - Manchmal steigt sie auch auf 12%
Arbeitsspeichernutzung liegt bei 4GB


Ich weiß leider nicht, wo man noch nachgucken könnte, warum die Seite so langsam lädt.

Hilfe ._.

27.07.2018 00:44
 
0     0
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden

Beiträge: 529
Bewertung: 32
Registriert seit: May 2012
Status: offline


Beitrag: #2
RE: Lange Ladezeiten bei Plesk

Sorry, hab die Glaskugel leider vergessen ...

Mal ehrlich, da braucht man schon einige mehr Infos Wink

Was für ne Webseite isses - statischer HTML wäre schon krass.
MySQL lastige Webseite kann schnell mal so "langsam" laden, wenn bei Windows ( ohhh welch Wunder) mal wieder im Hintergrund automatische Updates laufen und die gesamte I/O stören.

Spontan fällt mir jz nichts zu ein, CPU und RAM konntest du selbst ausschließen, also musses I/O sein, kanns aber auch nur, wenn deine Webseite ziemlich SQL lastig ist.

Ansonsten fallen mir noch externe Inhalte ein, die einfach länger brauchen oder auch die Bandbreite des Hosts - das ist jetzt fast alles ins Blaue geraten.

Aber Plesk auf Windows ... da muss man eigentlich schon automatisch auf Schmerzen stehen.


[Link: Registrierung erforderlich]

IxDe.eu | iTaLiaN-PoWeR
- Das Management

27.07.2018 01:04
 
0     0
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden

Beiträge: 528
Bewertung: 3
Registriert seit: Mar 2012
Status: offline


Beitrag: #3
RE: Lange Ladezeiten bei Plesk

italian-power schrieb:
Sorry, hab die Glaskugel leider vergessen ...

Mal ehrlich, da braucht man schon einige mehr Infos Wink

Was für ne Webseite isses - statischer HTML wäre schon krass.
MySQL lastige Webseite kann schnell mal so "langsam" laden, wenn bei Windows ( ohhh welch Wunder) mal wieder im Hintergrund automatische Updates laufen und die gesamte I/O stören.

Spontan fällt mir jz nichts zu ein, CPU und RAM konntest du selbst ausschließen, also musses I/O sein, kanns aber auch nur, wenn deine Webseite ziemlich SQL lastig ist.

Ansonsten fallen mir noch externe Inhalte ein, die einfach länger brauchen oder auch die Bandbreite des Hosts - das ist jetzt fast alles ins Blaue geraten.

Aber Plesk auf Windows ... da muss man eigentlich schon automatisch auf Schmerzen stehen.


Ich mach dies aus Hobby, bin also kein Profi oder mega Genie, was dies an geht.

Bei Linux hatte ich nur Probleme in bezug auf Plesk, weswegen ich auf Windows gewechselt bin. Da lief es am Anfang auch gut, nun kam halt dann die richtige Website und die braucht halt seeeeeehhhrr Lange zum laden.

Ich selber lass die Website über Wordpress laufen, also ja, ziemlich SQL lastig.

Mit I/O hatte ich bis dato nichts zu tun, weswege man eventuell hier eine Hand reichen müsste Smile

EDIT: Ich lasse auf dem Root Server momentan nur noch einen Teamspeak Server laufen, auf dem zwischen 5-10 Leute pro Tag drauf sind. Vielleicht hilft das ja

Grüße,

Dieser Beitrag wurde zuletzt bearbeitet: 27.07.2018 01:15 von DJ_Drio.

27.07.2018 01:11
 
0     0
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden

Beiträge: 529
Bewertung: 32
Registriert seit: May 2012
Status: offline


Beitrag: #4
RE: Lange Ladezeiten bei Plesk

Ich behaupte mal, dass es gerade für einen Laien besser ist auf Linux zu setzten, hier man viel mehr Auswahl an Software und auch Alternativen.

Brechreitz wirst du spätestens bekommen wenn du ein paar "Sonderregeln" im IIS definieren willst - an sich ist der IIS geil aber für nen Laien wohl eher problematisch.

Schau einfach mal ob Windows Updates gerade installiert werden, oder schick mir mal die Seite (gerne auch per PN)

Ich bezweifle, dass Teamspeak daran Schuld ist. Es kann halt auch ein kürzlich aktiviertes Wordpress Plugin sein.


[Link: Registrierung erforderlich]

IxDe.eu | iTaLiaN-PoWeR
- Das Management

27.07.2018 01:20
 
0     0
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden

Beiträge: 528
Bewertung: 3
Registriert seit: Mar 2012
Status: offline


Beitrag: #5
RE: Lange Ladezeiten bei Plesk

Die Website ist: [Link: Registrierung erforderlich]

Alle Updates wurden gestern für Windows durchgeführt, auch für Plesk sind alle Updates durchgeführt worden.

Bei Linux hatte ich immer das Problem, dass vieles einfach gar nicht funktionierte, egal was ich machen wollte. Selbst der Plesk-Installer hat meist dafür gesorgt, dass der Server eine Neuinstallation erfahren musste. Da ich den Root Server auch gerne für Gameserver verwenden möchte, ist hier Windows eine bessere wahl, da man dort die Gameserver einfacher uns sicherer aufsetzen kann.

Das Problem ist einfach, dass viele Hilfen, die im Internet angegeben werden, keine Erfolge erzielen, da diese nicht gut genug beschrieben sind. Meistens findet man nur: "füge das mal ein (code) und teste."

Keine sonderlich gute Hilfe

27.07.2018 01:25
 
0     0
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden

Beiträge: 529
Bewertung: 32
Registriert seit: May 2012
Status: offline


Beitrag: #6
RE: Lange Ladezeiten bei Plesk

Also bei mir passiert ziemlich genau 10 Sekunden lang nichts und dann kommt alles, auffällig ist dieses "autoptimize", ist das ein Plugin? Bitte beachte, dass viele WP Plugins (gerade Cache usw.) für Linux distros optimiert wurden und ggf. nicht so gut auf Windoof laufen. Es kann natürlich auch sein, dass der Cache korrekt funktioniert aber bspw. keine Schreibrechte hat und somit die Seite jedesmal "neu" cachen muss - in seiner optimierten datei oder whatever.

Auf jeden Fall mal alle Cache Plugins in WP deaktivieren und dieses autoptimize auch, dann Testweise nach und nach die APIs deaktivieren - ich sehe hier spontan Youtube und Googlefonts, Googlemaps, Facebook und Google selbst (vermutlich nicht das Problem), aber auch fontsawesome.com (sollte eigentlich auch nicht problematisch sein), die APIs werden gerade von WP Seiten oft und gerne genutzt.

Du kannst ja auch Testweise eine statische HTML Seite erstellen, oder besser eine PHP-Datei mit statischem HTML Inhalt - das sollte auf jeden Fall innerhalb von Millisekunden laden

Nur mal so am Rande : Du hast weder ein Impressum, noch eine Datenschutzerklärung


[Link: Registrierung erforderlich]

IxDe.eu | iTaLiaN-PoWeR
- Das Management

27.07.2018 01:38
 
0     0
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden

Beiträge: 528
Bewertung: 3
Registriert seit: Mar 2012
Status: offline


Beitrag: #7
RE: Lange Ladezeiten bei Plesk

Das Impressung ist noch im im Gange, ich hab jetzt gerade für die Problemlösung den Maintance Modus deaktiviert. Die Privacy Policy ist aktiv und muss bei der Anmeldung und Registierung akzeptiert werden. Dabei ist auch ein href zu finden.

Ich hab nun die zwei Cache Plugins Speed kit und autooptimize deaktiviert, sowie das Share Plugin, welches ich nutze. Die anderen Plugins werden für das Theme benötigt, da es sonst das Design zerbricht. Dabei habe ich eine Ladegeschwindigkeit von 6 sekunden erhalten.
Die Youtube API hab ich nun auch rausgenommen und so die gleiche Geschwindigkeit erhalten. Da hat sich nichts getan. Kann also nicht an der Youtube API liegen.

Die Standart Seite von Plesk, die Statische lädt sich innerhalb von 393ms...muss also an Wordpress selber liegen. Das ist doch schonmal etwas...darauf hätte ich auch selber kommen können...

Dann werde ich wohl meinen Weg nun mit dem Support vom Theme gehen müssen?

Grüße,

27.07.2018 01:55
 
0     0
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden

Beiträge: 529
Bewertung: 32
Registriert seit: May 2012
Status: offline


Beitrag: #8
RE: Lange Ladezeiten bei Plesk

Die Seite ist knapp 8 MB groß, 5 Sekunden sind noch ein gerade so akzeptabler Wert.

Wenn einfach mal caching aktivieren, sprich den Bildern Dateien usw. eine Lebensdauer von 1-2 Tage/Wochen (je nach Bedarf) zuweisen - dann sollte es schneller gehen.

Wordpress ist ziemlich gut, weil es viel kann - viele Funktionen heißt aber gleichzeitig overhead, im normalfall macht das aber vielleicht 200-300ms aus.

Meine optimierte Webseite lädt in 1-2 Sekunden (inklusive Background und weitere Images), ein WP Blog von mir in 800ms (beide via Cloudflare / nochmals Verzögerung), eine nginx default Seite in 200ms (Ohne CF)
Alles jeweils ohne Cache.

An einen Wert von 3-4 Sekunden kommst du vielleicht noch ran, darunter könnte es schwierig werden ohne größere Optimierungen - vor allem die externen Inhalte können die Ladezeit immens nach oben pushen, da scheint aber aktuell weniger das Problem zu sein.


[Link: Registrierung erforderlich]

IxDe.eu | iTaLiaN-PoWeR
- Das Management

27.07.2018 02:41
 
0     0
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden

Beiträge: 121
Bewertung: 8
Registriert seit: Aug 2016
Status: offline


Beitrag: #9
RE: Lange Ladezeiten bei Plesk

Eigentlich sind 8MB für eine Seite viel zu groß. Durch tinypng oder tinykpg bekommt man die bilder so komprimiert, dass sie nicht mehr all zu viel Speicher brauchen. Generell solltest du bei einer Seite unter 2MB bleiben. Mit einer 5000er Leitung wirst du ewig bei 8MB laden.

Ja, ich sehe auch, erst nach ungefair 10 Sekunden passiert was.

Da aber die Pleskt-Login Seite relative schnell läd, denke ich nicht, dass es an dem Server direkt liegt. Leider kenne ich mich mit Windows-Servern kaum aus und kann hier auch nicht sagen, ob das da dran liegt. Ich weis nur, dass ein Kunde von mir 30 Seite mit Plesk verwaltet. Er hat einen Root-Server mit lediglich 4 Kernen und 10 GB Ram. Alle Seite laufen zwar nicht optimal, sind aber unter 2s geladen...

Versuche es doch wirklich mal mit Linux. Wenn da Plesk drauf installiert ist, musst du doch sowieso keine Linuxbefehle können?

Noch eine weitere Sache: Plesk selber hat intern ein System, dass heißt Serverzustand. Hier zeigt er dir die Auslastung an. wenn die Auslastung gering ist, dann muss es eigentlich an der Seite liegen. Nehme bei de rSeite einfach mal alle externen Sourcen raus (fonts.google...) und lade sie selber auf deinen Webspace hoch.

Ich hoffe ich konnte ein wenig helfen. Aber so kann ich leider auch nicht viel sagen. Laden alle Seiten so langsam?


http://ottnec.de
ATHP: [Link: Registrierung erforderlich]

27.07.2018 09:26
 
0     0
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden

Beiträge: 600
Bewertung: 36
Registriert seit: Mar 2012
Status: offline


Beitrag: #10
RE: Lange Ladezeiten bei Plesk

Mache einfach mal mit Firefox eine Netzwerkanalyse, was die Seite laden muss und das aus wie vielen externen Quellen ist schon beachtlich. Ich denke das dies der Knackpunkt hier ist.


[Link: Registrierung erforderlich]
Aktuell vertrauen uns aktive 1350 Kunden mit ca. 2300 verschiedenen Serverprodukten
Gameserver mit Qualität und "Allem Drin" was Du brauchst! - Seit 2008!
[Link: Registrierung erforderlich]
Autorisierter TS3 Hoster [Link: Registrierung erforderlich]

27.07.2018 10:36
 
0     0
Alle Beiträge dieses Benutzers finden
Thema geschlossen  Thema schreiben 
 Seiten (2): « Erste 1 2 Nächste > Letzte »

Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Benötige hilfe bei Plesk und website. Ch3fK0cH 5 767 29.04.2019 18:13
Letzter Beitrag: ole
  Plesk/Wordpress Limit problem DJ_Drio 2 714 19.08.2018 06:42
Letzter Beitrag: DJ_Drio
  Brauche Hilfe mit Plesk Nesh 5 1.436 10.04.2018 17:50
Letzter Beitrag: RedDust
  Windows vServer Hilfe bei Einrichtung Plesk/IIS (nur ein paar kleine Probleme) Pilot 5 1.103 11.01.2015 13:44
Letzter Beitrag: push
  Plesk - nach Server neustart alle Daten wieder auf "Standart" Sky001 0 800 13.08.2014 13:17
Letzter Beitrag: Sky001

 Druckversion anzeigen
 Thema einem Freund senden
 Thema abonnieren
 Thema zu den Favoriten hinzufügen

Sponsor-Board.de

Community
Über uns
Partner
Powered by Mybb: Copyright 2002-2020 by MyBB Group - Deutsche-Übersetzung von Mybb.de
 
© 2007-2020 Sponsor-Board.de - Hosted by FSIT AG

Willkommen auf SB!   Sie benötigen ein Sponsoring?   1. Anmelden   2. Sponsoring-Anfrage erstellen   3. Nachrichten von Sponsoren erhalten   Kostenlos!   Jetzt registrieren