Sponsor-Board.de
Antwort schreiben  Thema schreiben 

Medienkonverter

Verfasser Nachricht

Beiträge: 1.529
Bewertung: 60
Registriert seit: Jan 2011
Status: offline


Beitrag: #1
Medienkonverter

Moin zusammen,

ich habe mich gerade mal was gefragt, worauf ich selber keine Antwort parat habe.

Also es gibt ja Medienconverter, die von Kupfer auf LWL übersetzen und ander herum. Nun zu folgenden Szenario:

Auf der einen Seite hast du ein Cat 6 Patchkabel (RJ45), welches über einen 100MBit (100Base-T) Switchport gespeißt wird. Auf der anderen Seite hast du den Medienconverter, der ebenfalls die 100MBit (100Base-T) auf Kupferbasis unterstützt. So, der LWL Port am Converter ist aber ein 1000BaseSX Port - unterstützt keinn 100Mbit. Auf der anderen Seite der LW Strecke ist das selbe Konstrukt.

Aufbau:

Zitat:
Switch (100Base-T) -> Konverter (100Base-T) -> Konverter (1000BaseSX) <------> LWL <--> Konverter (1000BaseSX) <- Konverter (100Base-T) <- Switch (100Base-T)


Nun tur Frage - kann das funktionieren?

Ich persönlich würde zu nein tendieren, da die gesamte Strecke nicht die selbe Übertragungsrate nutzt - aber erhlich gesagt bin ich bei dieser theorie auch überfragt. Was meint ihr dazu? Smile


PS: Ich baue dieses szenario gerade selbst daheim auf, bestehend aus 2 Cisco c2950, 2 Allnet Convertern (ALLNET ALL-MC103G-SC-MM) - hier simuliere ich gerade ein Komplexes Netzwerk und versuche derzeit diese Konverter mit zu integrieren - bekomme aber nur ne flappende Leitung mit In/Out errors.


Viele Grüße

Nico

[Link: Registrierung erforderlich]

Dieser Beitrag wurde zuletzt bearbeitet: 09.11.2015 13:55 von DebianDEV.

09.11.2015 13:52
 
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren

Beiträge: 3.322
Bewertung: 68
Registriert seit: Jul 2011
Status: offline


Beitrag: #2
RE: Medienkonverter

Hallo Nico,
Die gute Nachricht gleich zu beginn:
Deine Konstruktion müsste gehen. Ein Medienkonverter ist nicht viel anders als ein simpler 2 Port Switchs. Das heisst das Deine LWL Leitung mit 1000 Mbits betrieben werden, aber natürlich durch Dein 100 Mbits Interface beschränkt.

Es gibt aber etwa 3-4 Knackpunkte, welche Dir Probleme verursachen können. Ich bitte Dich einmal dies zu kontrollieren.

- Setzte bei den Medienkonverter und denn Switches die Ports (NICHT LWL Port) fix auf 100 Mbits Full Duplex.(Kein Auto Sensing) // Kannst natürlich auch die LWL auf 100 Mbits setzten, hat kein Impact.
- Die Kupfer (RJ45) Kabel sind nicht länger als 100 Meter (technische Grenze ist etwa bei 110Metter, würde aber nie über 100 Meter gehen)
- was verwendest Du für ein LWL Kabel ? -> Hier muss es ein Multimodekabel sein (62.5/125uq MM bis 220Meter und 50/125uq MM bis zu 550Meter. Länger wird Multimode nicht gehen.

Ich hoffe das es einmal fürs erste reicht. Ansonsten helfe ich Dir gerne noch weiter.

LG Alex


Wenn "Server" eine Religion ist, haben wir die passende Kathedrale dazu!

[Link: Registrierung erforderlich]

[Link: Registrierung erforderlich] - [Link: Registrierung erforderlich] - [Link: Registrierung erforderlich] - [Link: Registrierung erforderlich] - [Link: Registrierung erforderlich]
Mehr infos unter [Link: Registrierung erforderlich] oder [Link: Registrierung erforderlich]

 
 Bedankt hat sich:
DebianDEV (Nov-9-2015)
09.11.2015 14:14
 
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren

Beiträge: 1.529
Bewertung: 60
Registriert seit: Jan 2011
Status: offline


Beitrag: #3
RE: Medienkonverter

Hi Alex,

danke für deine promte Antwort Smile

Um direkt die vermeindlichen Knackpunkte anzusprechen:

- die Ports sind auf 100Mbit genagelt, fullduplex und noautonegotiation

interface FastEthernet0/24
switchport mode trunk
switchport nonegotiate
duplex full
speed 100
shutdown ### Im livemodus natürlich "no shutdown"
cdp enable
spanning-tree vlan 1-10 cost 30
spanning-tree vlan 11-20 cost 70
!

--- die andere Seite sieht ähnlich aus - ich arbeite (wie man sieht) mit einem Spanning-Tree (habe noch 2-3 switches mehr zuhause rumlungern, die mit eingebunden werden) und dementsprechend VLANs.

- Ich benutze jeweils 2,5m RJ45 cat6 Patchkabel. Um meinen Rechner mit den VMs mit dem Netzwerk zu verbinden verwende ich ein 15 Meter cat6 Patchkabel

- als Übertragungsmedium im LWL Bereich verwende ich eine 50/125uq MM über 100Meter (ausgeliehen von der Firma) - die MM ist soweit in Ordnung - wurde vor 6 Monaten in der Firma gemessen - Dämpfungswerte stimmen

Problem ist, dass ich wie beschrieben viele Input Output errors bekomme - ich bekomme zwischen 1-3 Mbit Banbreite mit dem Ding hin - wenn ich 2 100er (T und SX) Konverter anschließe, dann funktioniert es komischerweise. Die Konverter sind leider unmanaged, sodass diese selber die Bandbreite und Duplexmodus entscheiden - die Switches sind (wie in der Config beschrieben) auf Duplex und Speed genagelt.

Hast du sonst noch eine Idee für mich?


Viele Grüße

Nico

[Link: Registrierung erforderlich]

Dieser Beitrag wurde zuletzt bearbeitet: 09.11.2015 14:43 von DebianDEV.

09.11.2015 14:28
 
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren

Beiträge: 3.322
Bewertung: 68
Registriert seit: Jul 2011
Status: offline


Beitrag: #4
RE: Medienkonverter

Ich sehe schon, Du hast hier schon einiges ausprobiert.
ich würde folgende Sachen zuerst einmal ausprobieren:

- no Shutdown in der Config hinterlegen Wink
- Einmal ohne vlan und stp arbeiten. Einfach Simple Port anschliessen und schauen ob das auf der andere Seite ankommt - Könnte auch sein das er mit vlan und STP (vor allem mit vlan) rumspackt. Stelle also zuerst sicher ob der Konverter funktioniert.


Wenn "Server" eine Religion ist, haben wir die passende Kathedrale dazu!

[Link: Registrierung erforderlich]

[Link: Registrierung erforderlich] - [Link: Registrierung erforderlich] - [Link: Registrierung erforderlich] - [Link: Registrierung erforderlich] - [Link: Registrierung erforderlich]
Mehr infos unter [Link: Registrierung erforderlich] oder [Link: Registrierung erforderlich]

 
 Bedankt hat sich:
DebianDEV (Nov-9-2015)
09.11.2015 14:47
 
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren

Beiträge: 1.529
Bewertung: 60
Registriert seit: Jan 2011
Status: offline


Beitrag: #5
RE: Medienkonverter

Hi Alex,

- grins -> extra nochmal bearbeitet - natürlich ist der port up wenn ich das Teste - der ging mal auf "err-disabled" und daraufhin habe ich den Port shutdown gesetzt und dann wieder "up" genommen. - Das ist ne Config, die ich gerade auf Arbeit zur Hand habe, da ich ab und an von hier aus auch Arbeite *lach*

- Naja - ohne den Spanning Tree und geconfte VLANs gehts leider genauso wenig -- die Symptome bleiben die selben. Packet loss im Ping, I/O Errors, Frame und CRC Error.

Hier mal der Counteroutput:

Zitat:
s1test#sh int fa0/24
FastEthernet0/24 is up, line protocol is up (connected)
Hardware is Fast Ethernet, address is XXXXXXXmasked (bia XXXXXXXmasked)
Description: Uplink SV-test
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 9/255, rxload 14/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, media type is 100BaseTX
input flow-control is unsupported output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters 03:45:00
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 5783000 bits/sec, 767 packets/sec
5 minute output rate 3811000 bits/sec, 593 packets/sec
16688970 packets input, 2030555238 bytes, 0 no buffer
Received 994598 broadcasts (0 multicast)
0 runts, 0 giants, 0 throttles
8893 input errors, 4028 CRC, 4627 frame, 0 overrun, 1848 ignored
0 watchdog, 579855 multicast, 0 pause input
0 input packets with dribble condition detected
13125709 packets output, 3696164810 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out


Wie gesagt - mit reinrassigen 100er Convertern fluppt die Leitung wunderbar - nur mit den 1000er zickt er rum - echt komisch, wenn du sagst, dass es laufen sollte (100 -> 1000 -> 1000 -> 100)

Ich verzweifel echt langsam *seufz*


Viele Grüße

Nico

[Link: Registrierung erforderlich]

Dieser Beitrag wurde zuletzt bearbeitet: 09.11.2015 14:55 von DebianDEV.

09.11.2015 14:54
 
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren

Beiträge: 3.322
Bewertung: 68
Registriert seit: Jul 2011
Status: offline


Beitrag: #6
RE: Medienkonverter

Meine Aussage das es funktionieren sollte basiert nur auf der Annahme das es switched Medienkonverter sind, welche auf OSI-2 arbeiten. BEI OSI-1 Medienkonverter könnte es zu Problemen führen - Dies habe ich aber nicht gerade zur Hand leider um es zu testen für Dich.

Kannst Du die Konverter nicht einmal auf Gbits ausprobieren ? Zum Beispiel auf beiden Seiten ein PC anschliessen.

Was auch noch ausprobieren kannst, wenn das dein Switch kann die Flow Control auf den beiden Switchen zu aktivieren:

Zitat:
conf t
Interface fa 0/24
flowcontrol receive on
end
wr mem


Wenn "Server" eine Religion ist, haben wir die passende Kathedrale dazu!

[Link: Registrierung erforderlich]

[Link: Registrierung erforderlich] - [Link: Registrierung erforderlich] - [Link: Registrierung erforderlich] - [Link: Registrierung erforderlich] - [Link: Registrierung erforderlich]
Mehr infos unter [Link: Registrierung erforderlich] oder [Link: Registrierung erforderlich]

 
 Bedankt hat sich:
DebianDEV (Nov-9-2015)
09.11.2015 15:05
 
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren

Beiträge: 1.529
Bewertung: 60
Registriert seit: Jan 2011
Status: offline


Beitrag: #7
RE: Medienkonverter

Hi Alex,

jupp - mit dem aktiven flowcontrol läuft es - hatte mir auch nochmal die Anleitung rausgesucht - und tatsache "Back pressure flow control for full duplex" beherrscht der Controller auch im 100MBit Bereich - vermutlich wollte der Konverter die ganze Zeit die Leitung Kontrollieren, hats aber nicht geschafft, weil der Switch "Nein" gesagt hat ... Oh man ... Aber genau dafür baue ich mir solche Netzwerke *_*

Danke Alex !!!


Viele Grüße

Nico

[Link: Registrierung erforderlich]

 
 Bedankt hat sich:
Alex (Nov-9-2015)
09.11.2015 16:19
 
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren
Antwort schreiben  Thema schreiben 

 Druckversion anzeigen
 Thema einem Freund senden
 Thema abonnieren
 Thema zu den Favoriten hinzufügen

Sponsor-Board.de

Community
Über uns
Partner
Powered by Mybb: Copyright 2002-2021 by MyBB Group - Deutsche-Übersetzung von Mybb.de
 
© 2007-2021 Sponsor-Board.de - Hosted by OVH

Willkommen auf SB!   Sie benötigen ein Sponsoring?   1. Anmelden   2. Sponsoring-Anfrage erstellen   3. Nachrichten von Sponsoren erhalten   Kostenlos!   Jetzt registrieren